¿Estás preparado para WordPress 3.2?

¡Ah, que no lo sabes!

Pues está a punto de salir la versión mayor WordPress 3.2 y tendrá importantes novedades y, lo que es más importante en este momento, nuevos requisitos.

Así que ve tomando nota y comprueba si estás preparado para WordPress 3.2

Requisitos de WordPress 3.2

WordPress 3.2 trae requisitos a nivel de servidor, y recomendaciones de uso de navegadores en base a la iniciativa Browse Happy, toma nota:

  1. PHP 5.2.4 o superior (requerido)
  2. MySQL 5.0 o superior (requerido)
  3. Módulo mod_rewrite de Apache (requerido)
  4. Chrome 11 o superior (recomendado)
  5. Firefox 4 o superior (recomendado)
  6. Safari 5 o superior (recomendado)
  7. Opera 11.10 o superior (recomendado)
  8. Internet Explorer 9 o superior (recomendado)

¿Como compruebo mis versiones?

Aquí tienes unas indicaciones:

  1. Versión de PHP: Puedes revisar la página de información de tu proveedor de alojamiento o introducir la URL de tu sitio en este comprobador
  2. Versión de MySQL: Revisando la información de tu proveedor, con el plugin LAMP version checker o con el comando --version, -V
  3. Módulo Apache mod_rewrite: Lo más fácil para comprobar si está activo el módulo es introducir esto en tu fichero .htaccesss y probar a ver si puedes ver los archivos dentro de las carpetas a través del navegador:
    Options +FollowSymLinks
    RewriteEngine On

    Si no ves nada simplemente es que está instalado, si recibes un Error 500 es que no está activo

  4. Versión del navegador: Desde Browse happy tienes acceso a los enlaces de descarga de los principales

¡Ea, a prepararse tocan!

VALORA Y COMPARTE ESTE ARTÍCULO PARA MEJORAR LA CALIDAD DEL BLOG…
(2 votos, promedio: 1)

¿Te gustó este artículo? ¡Ni te imaginas lo que te estás perdiendo en YouTube!

AVISO: Esta publicación es de hace 3 años o más. Si es un código o un plugin podría no funcionar en las últimas versiones de WordPress, y si es una noticia podría estar ya obsoleta. Luego no digas que no te hemos avisado.

74 comentarios en “¿Estás preparado para WordPress 3.2?”

      1. Dos preguntas:

        1. ¿Exactamente por qué razón es eso de las versiones de los navegadores?

        2. ¿Lo que hoy es "recomendado" mañana será "obligatorio"?

          1. Lo que planteo es lo siguiente:

            Como usuario de Mac (OSX 10.4.11) me encuentro con el siguiente problema (mio y de más gente): el sistema sólo permite actualizar Safari a 4.1.3 y Firefox a 3.6.17. Para poder continuar actualizando me pide versión nueva del sistema operativo (pagando, por supuesto). Pero el problema no acaba ahí, podría volverle la cara a mi ética y piratear un sistema operativo, pero un Macbook no permite versiones del sistema mayores que 10.4.x, de modo que sólo para poder acceder a la administración de WordPress que no parece ofrecer nada diferente tendría que comprar un ordenador nuevo (pagando un dineral, eso lo sabes porque usas Mac) que pueda soportar versiones más modernas del sistema y me permitan administrar WordPress. ¿Es eso lógico?

            Y yo, que no quería arrepentirme de haber comprado un Mac, cuando veo los requisitos mínimos que exige Firefox para ser instalado, aseguro: con Windows no pasan estas cosas.

            Cuando preguntaba anteriormente por la razón de la exigencia de versiones del navegador era para asegurarme de que existe una razón tecnológica que hace imprescindible utilizar la versión más moderna de ambos navegadores. Por lo que leo en tu contestación, y por lo que no veo en ninguna web, no existe. Esto es lo que se denomina "obsolescencia programada", y hay una explicación del término en la Wikipedia (en castellano) aparte de en otros 333.000 resultados en Google. Para los que no somos consumistas compulsivos, "comprar por comprar" es inmoral, y la tecnología parece querer ser, ante todo, inmoral.

            Mientras no obtenga una explicación convincente del asunto, repartiré la culpa entre Apple (cuya política es "paga por todo, hasta por lo inútil") y WordPress, que parece que se apunta a la antiética después de esta maniobra sin razón lógica. El caso es que, de ser así, WordPress va a salir muy caro ¿no creéis?

            Resumiendo. Es absurdo tener que cambiar de ordenador sólo por un capricho al que encima le ponen un nombre, "browse happy" que es muy "chupi". Es más absurdo aún tener que hacerlo cuando tienes apreturas económicas propias del momento actual y aunque el ordenador funcione perfectamente tras 5 años (incluso la batería, que nunca he cambiado, todavía tiene dos horas de autonomía). ¿Tiene sentido, entonces, cuidar las cosas? (Para el que le importe la ética, que se informe del serio problema de las toneladas de basura tecnológica que se están generando y dónde acaban)

            Concluyendo: Sin darle demasiadas vueltas al asunto, lo que me imponen desde WordPress es la obligatoriedad absurda de cambiar de ordenador o de plataforma de blog. Por supuesto, es más barato cambiar de plataforma de blog, así que ¡bravo por la decisión de WordPress! han sido muy inteligentes en su política de fidelización y muy hábiles con eso de la ética.

            Finalmente toca "ponerse colorado" para explicarle a un cliente que tiene una revista online que su Mac no sirve para administrar su WordPress, que tendrá que cambiar las x máquinas de su empresa sólo para que su gente pueda seguir trabajando o continuar haciéndolo con una versión cada día más "caduca" de WordPress que no podrá ser actualizada sin pasar por un desembolso más que serio de dinero para el bolsillo de un tercero. A su primera pregunta -¿por qué?- no tengo respuesta profesional posible. ¡Ah! no olvidemos que una de las cosas que se le venden a los clientes es que su plataforma de blogs estará siempre actualizada y segura. Esto se le vende y se le cobra, claro.

            Gracias por leerme. Saludos.

          2. Ante un soft el equipo de desarrollo esta en su completo derecho a hacer lo que mejor creo necesario y el resto si queremos lo usamos y sino pues nada. Y mas aun en el caso de que sea gratuito.

            Todo lo que comentas esta muy bien, pero en todo eso no has evaluado el dinero que te ha ahorrado wordpress, claro, como es gratis pues ala, todos a trabajar para mi y encima yo exijiendo.

            Hasta la fecha el equipo de WordPress ha demostrado ir por el buen camino, y como he dicho antes, el que no quiera seguir ese camino pues pista.

            Yo por mi parte estoy encantado con la nueva version, funciona perfectamente la RC y eso que ni tengo un hosting de la hostia ni mi ordenador es una bomba de las nuevas y ni mi windows lo es.

          3. No, Álvaro, no te equivoques. Hasta ahora estoy completamente agradecido a WordPress, y no sólo porque sea gratuito y abarate el coste a un cliente. No exijo absolutamente nada, pido una explicación  *a quien la sepa* sobre algo a lo que no veo lógica. Eso es, hasta donde yo creo, mi derecho y el de todos, aparte de una obligación profesional (que parece que no has conseguido entender).

            Tú no quieres saber las razones de las cosas, y me parece muy bien, pero yo sí (por cierto, la palabra "exigir" la has escrito tú, no yo, quede claro).

            Como puedes leer, expongo una situación con la que me encuentro, y procuro encontrar una solución con el mínimo impacto para mí y para mis clientes, que son, en definitiva, quienes hasta ahora se han ahorrado dinero (no yo). Si a ti no te afecta ese problema, deja que a los que sí nos afecta intentemos solucionarlo. Si tú estás de acuerdo con todo, acepta que algunos no lo estemos y necesitemos una explicación que poder dar a aquellos que nos pagan para comer, porque ellos sí que pueden exigirla.

            Nuevamente, gracias a Fernando por tener este espacio para poder preguntar.

          4. Joder, no sabia eso de Apple. Definitivamente no entiendo a la gente que se lo compra.

            Para tu problema tienes una solución bastante sencilla. Instálate el VirtualBox y si no quieres piratear nada bájate algún sistema GNU/Linux (te recomiendo Linux Mint 11 que es el que actualmente estoy usando y viene con Firefox 4.0.1 de serie) y problema solucionado. Además, si no te gusta mucho Firefox te puedes instalar la última versión de Google Chrome y de Opera, menos Safari e Internet Explorer te puedes instalar todos.

            Y ya lo sabes, para la próxima vez cómprate un PC y no un Mac, te salen mucho más baratos y puedes hacer con ellos lo que quieras, no como con Apple… Si a lo que vas es a por diseño, como todos los Apple fan boys le pones unas luces de neón al PC y listo, XD.

            ¿Se me nota cuánto quiero a Apple no? ¬¬

          5. Veo que no has entendido _nada_ de lo que he escrito.

            1. Yo no uso WordPress, ni nada parecido. Las actualizaciones de mi propia web las hago en html plano porque no necesito más. Uso WordPress porque se adapta a las necesidades de mis clientes.

            2. Yo no soy nadie para decirle a un cliente qué debe y qué no debe comprar ¿tú sí? No es cosa mia meterme en sus políticas de empresa, ellos gastan su dinero en lo que quieren y como quieren. Yo soluciono lo que me proponen, cobro y vivo. Es fácil de comprender ¿no? No se pueden elegir clientes en función del sistema que utilizan cuando mi familia depende de mi trabajo.

            3. Si tengo un Mac, es cosa mía y, quizá sea porque trabajo con programas que exigen trabajar con Mac y sólo con Mac. Desde 1998 uso Linux, únicamente Debian y sólo en consola porque me basta. Además utilizo otros dos sistemas operativos. Sé lo que uso, para qué y por qué razón lo uso.

            Por favor, haz una lectura comprensiva de _todos_ los comentarios anidados antes de intentar convencerme de lo que ya sé hace más de diez años. Gracias.

            Saludos.

          6. Definitivamente no te entiendo… ¬¬

            1. Me parece muy bien que tú no uses WordPress, con que lo soliciten tus clientes lo tienes que usar, por lo tanto lo usas (no se si se me entiende). Y al usarlo necesitas de software que soporte WordPress.

            2. Estoy de acuerdo pero que no pidan peras al olmo, o quieres una cosa o otra (o quieres usar WordPress y actualizar Mac OS o no quieres pagar la actualización y no usar WordPress o usar una versión antigua del mismo). Al igual que tú que tienes que usar Mac obligatoriamente para lo que necesitas (imagínate que para editar vídeos necesitas hacerlo con Final Cut Studio, pues obligatoriamente tienes que hacerlo con un Mac), pues  ellos tienen que hacer lo mismo, si ellos quieren trabajar con WordPress tienen que tener software compatible con la plataforma, en este caso un SO actualizado y especifico (en este caso vuelvo a lo mismo, eso solo les pasa a los de Mac). Si quieres trabajar con unas herramientas especificas tienes que saber sus consecuencias… Pasa con los productos de Adobe en Linux por ejemplo…

            3. Exacto, si tienes un Mac es cosa tuya y problema tuyo. Si usas Mac y no quieres o no puedes actualizar el SO para poder usar WordPress atente a las consecuencias. Todo tiene sus pros y sus contras, y en este caso eligieron trabajar con Mac y ahora se puede ver sus contras.

            Con todo esto lo que te quiero decir es que no le eches la culpa a WordPress de hacer su trabajo. En este caso de aligerar la plataforma y que, menos para los usuarios de Mac, para todos los demás no nos debería de suponer ningún problema ya que lo que piden no es nada descabellado. Y te repito, tu caso tiene solución con el VirtualBox y un SO GNU/Linux, pero si quieres usar WordPress en Mac tienes que apechugar, es la contra o desventaja de usar ese SO, tu has elegido trabajar con Mac. (cuando digo tú, me refiero también a tu/s cliente/s)

            Y por cierto, siempre procuro leer los comentarios antes de responderlos y aún habiéndomelos leído otra vez sigo diciéndote lo mismo…

            Saludos!!!

          7. Por cierto, no le eches la culpa a WordPress. Desde hace muchísimo tiempo estamos reclamándoles a WordPress (bueno, a Automattic) que aligeraran un poco WordPress en general, incluido el paquete de instalación.

            ¿Ahora que lo hacen les criticamos?¿Para que queremos usar software obsoleto que es gratuito? Por que aquí lo que dices tu del consumismo no sirve. En el software referente al servidor como lo es Apache, PHP y MySQL son totalmente gratuitos, y en lo referente a los navegadores son todos totalmente gratuitos.

            Entonces, ¿para que queremos conservar software desfasado si podemos tener la última versión totalmente gratis?

            La culpa en tu caso la tiene quien la tiene… Yo uso GNU/Linux (y a veces Windows 7) y ningún problema. Y no voy a tener que pagarme un ordenador nuevo como tu.Échale la culpa a esa fantástica empresa llamada Apple, cuya empresa lleva la libertad por bandera. Ella es la que no te deja instalar el último software (aún siendo gratuito) sin pasar por caja. Y te repito que ese software para todos los demás es gratuito y no nos cuesta nada, menos, como veo, para los usuarios de Mac.

            Y a tu cliente con la revista online dile que cuando vaya a comprar un ordenador lo compre con cabeza, ya que si ni tu ni el os gusta el consumismo, perdona que te diga pero os habéis metido en la boca del lobo. Precisamente os habéis metido en la peor empresa si no tienes dinero o no quieres gastar en exceso o si no te gusta el consumismo compulsivo. Porque Apple precisamente se nutre de eso, del consumismo compulsivo de sus clientes.

            (Me alegro y todo de que les pase esto a los usuarios de Mac, para que abran los ojos y se den cuenta de la fantástica empresa que es Apple, muy bonita por fuera pero por dentro un asco).

            ¿Otra vez se me a notado cuánto quiero a Apple y el aprecio que la tengo no?

            Saludos!!!

          8. ¿Esto te lo inventas o que?

            Yo estoy con un Powerbook G4 (de los PowerPC de toda la vida) y estoy corriendo Firefox 4 tranquilamente (no la oficial porque dejaron de lado a PowerPC), así que no creo que tenga mucho problema en entrar a la administración.  Y ese equipo tiene 5 años ya.

            ¿En windows no pasa el que? pasa lo mismo.

            Si tu no quieres actualizarte es tu problema, pero no vengas

          9. Admite leopard

            Nombre del modelo: MacBook Pro
              Identificador del modelo: MacBookPro8,1
              Nombre del procesador: Intel Core i5
              Velocidad del procesador: 3,31 GHz
              Cantidad de procesadores: 1
              Cantidad total de núcleos: 4
              Caché de nivel 2 (por núcleo): 256 KB
              Caché de nivel 3: 6 MB
              Memoria: 8 GB
              Velocidad del bus: 400 MHz
              Versión de la ROM de arranque: MBP81.0047.B04

          10. MacBook, no MacBook Pro 😉

            Y toda esta política se llama obsolescencia programada que, por supuesto, no comparto.

            Nombre del modelo:    MacBook
              Identificador del modelo:    MacBook1,1
              Nombre del procesador:    Intel Core Duo
              Velocidad del procesador:    2 GHz
              Número de procesadores:    1
              Número total de núcleos:    2
              Caché de nivel 2 (por procesador):    2 MB
              Memoria:    2 GB
              Velocidad del bus:    667 MHz
              Versión de la ROM de arranque:    MB11.0061.B03
              Versión SMC:    1.4f12

      2. De igual forma es medio excluyente, ya que muchos estan pegados a IE y el usar la version 9 implica usar win7… Se ha tenido en cuenta que la mayoria de los usuarios que navegan en internet aun usan IE7? No lo digo yo, son muchas las estadisticas. Cualquiera que tenga un blog que no toque temas referentes a personas medianamente experimentadas lo pueden ver en su Analitycs.

        En fin; nada se puede hacer… creo!

        1. Aunque los que usan todavía Windows XP no pueden instalarse IE9 sí pueden instalarse las últimas versiones de otros navegadores como Firefox, Chrome, Opera e incluso la versión de Safari que existe para esta plataforma.

          En Windows opciones siempre existen. Y por lo demás son recomendaciones, habría que ver hasta qué punto IE8 soporta la nueva versión de WordPress.

  1. Bueno ¿Y cuáles son las mejoras?, ¿Por qué debemos actualizarnos?, ¿Qué ganamos con la nueva versión?, ¿Merecerá la pena?, ¿Habrá problemas de actualización? ¿Y los plugins?

    1. Merecerá la pena, eso seguro, estoy preparando un post con todas las novedades. En cuanto a los plugins, todos los que usen funciones de PHP 4 tendrán problemas claro

  2. Parece que mi hosting pasa todos los requisitos, perfecto, ahora solo queda que salga WP cuanto antes para migrar a la nueva versión, aunque por lo que veo habrá que echarle un ojo a todos los plugins

  3. Fernando, ¿Podrías explicar cómo actualizar el PHP 5.2.4 de un servidor dedicado en Plesk 9.5 y CentOS 5? Te estaría eternamente agradecida. Un saludo!

    1. Sinceramente, si no lo sabes no deberías tener un dedicado autoadministrado. Necesitas conocimientos básicos del sistema operativo que ejecuta tu servidor

  4. Fernando, ¿Podrías explicar cómo actualizar el PHP 5.2.4 de un servidor dedicado en Plesk 9.5 y CentOS 5? Te estaría eternamente agradecida. Un saludo!

  5. Pregunté a quien me alquila el hosting y me dice que estoy en condiciones en lo referente a Php y MySQL, pero me dice que el modulo Apache mod_rewrite es para los servidores con windows (el mío es linux). Disculpá la pregunta tan básica: ¿es cierto eso o es un verso de quién atiende el chat un domingo por la tarde?De paso, muchas gracias por tu página. Te sigo casi desde que la comenzaste y me ha sido de muchísima utilidad práctica para animarme a hacerle algunas cosillas a mi blog.

    1. Hasta donde se, mod_rewrite es para todos, sea Linux o Windows o lo que sea. Es lo que hace las URLs "amigables".

      Y sobre tu pregunta, no la entendí.

  6. Rodolfo Pilas

    Me das una mala noticia.  Yo tengo casi todos los wordpress que requieren alta performance de servicios servidos por lighttpd y cherokee web servver.

    Lamento mucho que wordpress se "case" con mod_rewrite. Si el instalador o algo de su funcionamiento interno revisa la exigencia de mod_rewrite, voy a estar en problemas.  Una cosa es la exigencia de reglas re rewrite y otra la exigencia del módulo.

    1. Se exige la regla mod_rewrite y CREO que todo servidor dispone de algun módulo que haga eso. Que me corrija Fernando si me equivoco.

    2. Yo lo he probado con nginx y funciona perfectamente.

      Hasta donde yo se, creo que lighttpd soporta perfectamente mod_rewrite aunque es posible que la configuración la tengas que hacer a mano.

  7. Para comprobar desde consola que version de Mysql es el comando q pusiste debería ser:
    mysqlcheck –version
    o
    mysqlcheck -v
    O usas uno o el otro en la consola
    Para comprobar la version de PHP en consola teclear simplemente:php -v
    Y listo! si usas consola es lo mas sencillo
    También podrías subir un phpinfo q es sencillo, solo basta subir un archivo con el nombre q quieran con extensión .php (ej: versin.php) y dentro del archivo tiene q estar:
    luego van a http://www.midominio.com/version.php y obtienen toda la data sin necesidad de instalar plugins en wordpress.

  8. Pingback: WordPress 3.2 más exigente con tu hosting web, Carrero

  9. Si mi PHP y mi MySQL no cumplen los requisitos los debe actualizar mi servidor o yo? Y si es así como se hace? Muchas gracias…por cierto yo por si acaso no me cambiaré a wordpress 3.2 hasta que no sea seguro

  10. Bueno después de crear un php.info y menterlo dentro de mi Ftp en la raíz he comprobado que dispongo de MySQL 5.0.X y de PHP5.3 ahora lo que me falta es eso del Apache…donde exactamente debo meter el código en el ,httaccess

      1. Ok, pues lo introduciré para ver que tal. Mi servidor es OVH y en principio tal y como he dicho al hacer el info.php me sale todo con las versiones necesarias. Ahora sí, espero que mi blog no haga plufff y desaparezca de la faz de la esfera.

  11. Bueno después de crear un php.info y menterlo dentro de mi Ftp en la raíz he comprobado que dispongo de MySQL 5.0.X y de PHP5.3 ahora lo que me falta es eso del Apache…donde exactamente debo meter el código en el ,httaccess

  12. J.J.Domínguez

    Parece que nosotros pasamos el examen, pero la verdad es que la primera impresión tras la lectura, es que no lo hacíamos ni con un aprobadillo raspao.

  13. Bien he puesto el código y puedo ver las carpetas de mi blog desde el navegador y en algún caso se pone en blanco. Nada de Error 505, entiendo que eso y que el MySQL y el PHP están correcto estoy preparado para el 3.2? Gracias por todo

    1. Pues no es así, la versión 5.2.4 es más antigua porque fue liberada en agosto de 2007. La versión 5.2.14 es mucho más reciente, de julio de 2010, para ser exactos.

  14. Lo del mod_rewrite será obligatorio o opcional/recomendable? 

    Actualmente no disponemos de un servidor web Apache y el mod_rewrite no lo podemos activar.

  15. Lo del mod_rewrite será obligatorio o opcional/recomendable? 

    Actualmente no disponemos de un servidor web Apache y el mod_rewrite no lo podemos activar.

  16. Acabo de montar un blog a modo de prueba y todo correcto. Compatible con mi hosting, mi tema, mis pluggins y por lo menos en lo mas basico perfectamente compatible con internet explorer 8.

    Aun asi esperare a la version final.

  17. Por cierto, ¿alguien sabe si en la version 3.2 hay cambios a nivel de estructura de base de datos?. Es decir, si instalo la 3.2 y revienta algo, ¿puedo borrar y volver a poner la version 3.1.3 sin ningun problema?.

  18. Pingback: Las novedades de WordPress 3.2 | Ayuda WordPress

  19. Al final no me he podido resistir, a mi es que estas cosas me superan, version 3.2 RC funcionando perfectamente y sin ningun problema. 🙂

    Como siempre, muy buen trabajo del equipo de desarrollo de WordPress.

  20. Pingback: Lo mejor de mi RSS del 13 al 19 de junio | Linux Hispano

  21. Pingback: VIDEO: WORDPRESS LANZA NUEVO MODO DE ESCRITURA | deskblog

  22. Pingback: WordPress lanza nuevo modo de escritura « NERDOGEEK

  23. Pingback: Solución para el error de Feedwordpress en Wordpress 3.2 | K-Government

  24. Marcos Alberto Sanma

    WordPress: 3.2
    PHP: 5.2.12
    MySQL: 5.0.92-community-log
    WebServer: ApacheEn RedCoruna, está bien que un hosting tenga las cosas actualizadas aunque hay versiones más nuevas, creo que PHP va por la 5.3 pero bueno por ahroa no la necesito.

  25. Pingback: Solución al error en los foros de BuddyPress 1.2.8 con wordpress 3.2 | K-Government

  26. Pingback: VIDEO: WORDPRESS LANZA NUEVO MODO DE ESCRITURA | My Blog

  27. Mi duda es si WordPress está preparado para una nueva versión. Con la actual ya hay plugins que se han quedado semifinal-obsoletos y son plugins muy usados. Veremos que pasa con la nueva …

    Saludos

  28. WordPress está preparadísimo, otra cosa son algunos desarrolladores de plugins, que no se adapten a los cambios.

    Ya se tomó la decisión hace tiempo de ir hacia adelante, y me parece acertada

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

 

Ir arriba Ir al contenido